Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives :: Books
Support This Site: Contributors :: Advertise


It is currently Aug Fri 18, 2017 12:19 am


All times are UTC [ DST ]





Post New Topic Post Reply  [ 9 posts ] 
Author Message
 Post subject: Help with Wards Arline GHJ-2060A
PostPosted: Jan Thu 05, 2017 12:11 am 
New Member

Joined: Jan Wed 04, 2017 11:50 pm
Posts: 4
Hello, This is my first post. I recently got a Wards Airline Phono Cabinet Model GHJ-2060A. The sound only comes out of one speakers. I have verified both speao I figure it must be an issue with the board. I do not have expertise with these boards. Can anyone help? I have attached photos. kers work by switching the wires. S


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Thu 05, 2017 8:34 pm 
Member
User avatar

Joined: Apr Tue 07, 2015 8:31 pm
Posts: 163
Location: Blue Lake, ME
speciialj wrote:
Hello, This is my first post. I recently got a Wards Airline Phono Cabinet Model GHJ-2060A. The sound only comes out of one speakers. I have verified both speao I figure it must be an issue with the board. I do not have expertise with these boards. Can anyone help? I have attached photos. kers work by switching the wires. S

Make sure your switches are clean and your plugs to the speakers are clean but before you start if you are not familiar with electronics you could post photos and your questions here. There are many people here who will help you.

_________________
.
That's MISTER "Grouchy Old Bastard" to you!


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Fri 06, 2017 6:36 pm 
New Member

Joined: Jan Wed 04, 2017 11:50 pm
Posts: 4
Thanks. I have crimped all new wires so I know its not that. I have also re-soldered the board at the left speaker terminal. Still no luck. I have attached some photos. I hope it helps!


Attachments:
IMG_1043.jpg
IMG_1043.jpg [ 105.97 KiB | Viewed 717 times ]
IMG_1040.jpg
IMG_1040.jpg [ 190.04 KiB | Viewed 717 times ]
IMG_1042.jpg
IMG_1042.jpg [ 187.87 KiB | Viewed 717 times ]
IMG_1044.jpg
IMG_1044.jpg [ 121.59 KiB | Viewed 717 times ]
Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Fri 06, 2017 11:51 pm 
Member

Joined: Feb Sat 06, 2016 1:47 am
Posts: 2059
Location: Santee Calif. 92071
Could be defective Electrolytic capacitors. The round blue ones and round black ones. Sometime can see crud leaking from under them. Also open audio output transistor. If you don't have any test Equipment there is an old time way to test capacitors and transistors with just a volt ohm meter. Google kick test electrolytic capacitors. And test transistors as diodes.


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Sat 07, 2017 12:01 am 
New Member

Joined: Jan Wed 04, 2017 11:50 pm
Posts: 4
Thanks, I will work on that. Do you know if there is any way to remove the board? It's hard to work on while hanging.


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Sat 07, 2017 1:31 am 
Member

Joined: Feb Sat 06, 2016 1:47 am
Posts: 2059
Location: Santee Calif. 92071
Unkown for sure. Take knobs off. Cover plate may lift off or have some screws holding in place. Chassis will then be exposed. Remove mounting screws. Chassis may lift out top. Or drop out bottom.


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Sat 07, 2017 5:17 pm 
Member

Joined: May Sat 06, 2006 4:03 am
Posts: 2687
Location: ZIP 23831 South of Richmond, VA 25 miles down the pike.
As I understand it, both speakers work, but not on left channel? You haven't said you've cleaned the selector switch, loudness, balance, bass, treble. If not hopefully a good cleaning could solve your problem. I don't think the crossover capacitor could be the problem unless it is opened. The left side is identical to the right side. You could visually check left against right for indications as noted in previous posts. A capacitor in the left channel could be the problem but a lot of the time it's a blown output or AF amp transistors. You need to do voltage checks on your left channel. This is sometimes physically hard unless chassis can be accessed and all power still connected.
Bill J.


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Sat 07, 2017 7:16 pm 
New Member

Joined: Jan Wed 04, 2017 11:50 pm
Posts: 4
NumberMaj 1 wrote:
As I understand it, both speakers work, but not on left channel? You haven't said you've cleaned the selector switch, loudness, balance, bass, treble. If not hopefully a good cleaning could solve your problem. I don't think the crossover capacitor could be the problem unless it is opened. The left side is identical to the right side. You could visually check left against right for indications as noted in previous posts. A capacitor in the left channel could be the problem but a lot of the time it's a blown output or AF amp transistors. You need to do voltage checks on your left channel. This is sometimes physically hard unless chassis can be accessed and all power still connected.
Bill J.


Yes, that is correct. How do you clean the selector switch? Some rubbing alcohol and a q-tip? Where is the capacitor in the left channel? I don't know how to do a voltage check...can you walk me through it? Sorry, I am a novice, but trying my best!

Jeff


Top
 Profile  
 
 Post subject: Re: Help with Wards Arline GHJ-2060A
PostPosted: Jan Wed 11, 2017 11:04 pm 
Member

Joined: Feb Sat 06, 2016 1:47 am
Posts: 2059
Location: Santee Calif. 92071
Use spray can of contact cleaner. Has a straw to shoot cleaniner into controls and switches. I think the cross over capacitor is okay. Normally would still get some sound without it.


Top
 Profile  
 
Post New Topic Post Reply  [ 9 posts ]  Moderator: Alan Voorhees

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 9 guests



Search for:
Jump to:  




















Privacy Policy :: Powered by phpBB