Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives :: Books
Support This Site: Contributors :: Advertise


It is currently Dec Sun 17, 2017 1:33 am


All times are UTC [ DST ]





Post New Topic Post Reply  [ 3 posts ] 
Author Message
 Post subject: AMI F 120 Jukebox stopped returning records!
PostPosted: Nov Fri 24, 2017 5:17 pm 
New Member

Joined: Jun Mon 20, 2016 4:13 am
Posts: 11
It retrieves a record and put it down with no issue. However when the record is done it will not put it back. Any ideas here?

I have a video of this here, https://youtu.be/-b4E8t9Clbc

Anyhelp would be greatly appreciated!!


Top
 Profile  
 
 Post subject: Re: AMI F 120 Jukebox stopped returning records!
PostPosted: Nov Fri 24, 2017 11:35 pm 
Member

Joined: Jan Mon 04, 2010 2:52 am
Posts: 2237
I don't have an electrical print for this jukebox before me, nor am I knowledgeable at all on jukeboxes (as I mentioned previously). With that being said, and given the successive problems that you are experiencing with this jukebox, I don't think that it would hurt by giving all of those contacts on that cam a complete ohmic check. Clean any contact which doesn't pass muster. Just be sure that the power is removed before checking/cleaning any of those contacts.

I suppose that you could also disconnect the power at the time that the gripper fails to return the record to the slot, and check each of those contacts (and/or observe anything else that obviously seems to be out of whack) which are closed.

I could very well be shooting in the dark here as I don't really know what that tone arm is actually tripping as it skates past the last groove.


Top
 Profile  
 
 Post subject: Re: AMI F 120 Jukebox stopped returning records!
PostPosted: Nov Tue 28, 2017 4:20 am 
Member

Joined: Feb Fri 17, 2012 5:13 am
Posts: 390
Location: Rockville, CT. 06066
Can you cancel the record from the switch on the back of the machine? If so, the trip switch in the bottom of the mech is out of adjustment. If not, all the contacts on both sides of the cam need to be checked for proper setup. See attached drawing. Many symptoms with this changer can be cured this way. Some of the other problems you have posted in other threads can be related to these switches.
Attachment:
AMI switches sm.jpg
AMI switches sm.jpg [ 221.03 KiB | Viewed 109 times ]


Top
 Profile  
 
Post New Topic Post Reply  [ 3 posts ]  Moderator: Alan Voorhees

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests



Search for:
Jump to:  


















Privacy Policy :: Powered by phpBB