Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives :: Books
Support This Site: Contributors :: Advertise


It is currently Dec Mon 11, 2017 5:07 am


All times are UTC [ DST ]





Post New Topic Post Reply  [ 6 posts ] 
Author Message
 Post subject: Newly purchased/refurbished Webcor Ravinia has a problem
PostPosted: Dec Mon 04, 2017 7:05 pm 
New Member

Joined: Oct Tue 24, 2017 2:07 am
Posts: 16
Hello,

Can you please help diagnose the problem with my newly refurbished Webcor Ravinia. I was just playing it now and all of a sudden the signers voice got very wobbly sounding and the record speed off and I can hear a very light clicking from under the player. Thoughts?


Top
 Profile  
 
 Post subject: Re: Newly purchased/refurbished Webcor Ravinia has a problem
PostPosted: Dec Mon 04, 2017 8:12 pm 
Member

Joined: Jan Mon 16, 2012 4:15 pm
Posts: 3589
Location: Near Brandon, Iowa
Idler wheel shed a patch of rubber? Maybe a bit of lube migrated onto the idler wheel rim? Should be fairly easy to pull the platter and investigate.


Top
 Profile  
 
 Post subject: Re: Newly purchased/refurbished Webcor Ravinia has a problem
PostPosted: Dec Mon 04, 2017 9:27 pm 
New Member

Joined: Oct Tue 24, 2017 2:07 am
Posts: 16
Yeah, checked the idler wheel which is new and seems fine. Seems to be getting worse. Just tried a record again and the platter barely even spins now. All parts seem very well lubed.


Top
 Profile  
 
 Post subject: Re: Newly purchased/refurbished Webcor Ravinia has a problem
PostPosted: Dec Tue 05, 2017 10:35 pm 
Member

Joined: Jan Wed 16, 2013 12:04 am
Posts: 1077
Location: 77001
1. Can you see the motor turning when idler wheel
is pulled away from rotor ?

2. Have you removed and rebuilt/cleaned the motor ?

Old oil/lubricant once heated up by motor friction can
appear. Either bond to bearings and slow the
motor, or liquefy and come out on idler, et cetera.

This is not uncommon even when the motor has
been cleaned, if the bearings were not soaked
in solvent to loosen/wick out the old lubricant.

3. Were the motor mounts changed out with
new ones ?
Hotwax


Top
 Profile  
 
 Post subject: Re: Newly purchased/refurbished Webcor Ravinia has a problem
PostPosted: Dec Thu 07, 2017 6:15 am 
New Member

Joined: Oct Tue 24, 2017 2:07 am
Posts: 16
Umm...crazy it started working again on it's on. So I'm going to monitor it and see what happens.


Top
 Profile  
 
 Post subject: Re: Newly purchased/refurbished Webcor Ravinia has a problem
PostPosted: Dec Thu 07, 2017 6:16 am 
New Member

Joined: Oct Tue 24, 2017 2:07 am
Posts: 16
Deleted


Top
 Profile  
 
Post New Topic Post Reply  [ 6 posts ]  Moderator: Alan Voorhees

All times are UTC [ DST ]


Who is online

Users browsing this forum: Robert Caston and 8 guests



Search for:
Jump to:  


















Privacy Policy :: Powered by phpBB