Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives
Support This Site: Contributors :: Advertise


It is currently Nov Mon 18, 2019 9:21 am


All times are UTC [ DST ]





Post New Topic Post Reply  [ 3 posts ] 
Author Message
 Post subject: Strange volume swells on record player
PostPosted: Sep Tue 10, 2019 5:23 am 
New Member

Joined: Sep Sun 08, 2019 9:09 pm
Posts: 22
hey guys so i have this old grundig 8080 that i fixed up. did all the recaps for the paper, waxed dipped, electrolytic, and filter caps. Changed one tube EM34 (glowing eye tube). and for some odd reason like very minute or so when im playing a record the volume dips or gets really loud.

Now at first i thought maybe something was wrong with record i was playing so i tried another one, but it did the same thing. So i thought maybe the record player was malfunctioning could be a bad needle or a dirty needle. So i went ahead and used a turntable that i know does work and plugged it into the 8080 but it still did the same thing. after a minute or so the volume either went up or went down. to double check that it was just the record player i switched over to the radio and listened to it for a good hour or so but the radio played fine. the radio side of the unit didn't have any changes in volume. only the record player.

do you guys think it is a tube or did i screw something up during the recap?


Top
 Profile  
 
 Post subject: Re: Strange volume swells on record player
PostPosted: Sep Tue 10, 2019 2:50 pm 
Member

Joined: Aug Sun 23, 2015 6:01 pm
Posts: 994
Location: South Jersey East of Philly
All audio generally goes thru the same circuit path on radio/phonos...so with the radio playing OK, I'm pretty sure your amp is OK. Just check the signal path from the phono input jack to the 1st audio tube for cold solder or faulty resistors, etc. Also...maybe the function switch has dirty contacts on the phono function...not unusual on a German set..


Top
 Profile  
 
 Post subject: Re: Strange volume swells on record player
PostPosted: Sep Wed 11, 2019 2:38 pm 
Member

Joined: Aug Sat 01, 2009 2:23 pm
Posts: 1700
If it has a socket for a remote control in the back, there are contacts activated by plugging in the remote control that switch volume control over to the remote unit. The contacts on these switches get dirty and that causes the volume shifts. You can try to verify this by tapping on that socket while a record is playing.

_________________
John Stone
Antique Radio Club of Illinois


Top
 Profile  
 
Post New Topic Post Reply  [ 3 posts ]  Moderator: Alan Voorhees

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests



Search for:
Jump to:  




























Privacy Policy :: Powered by phpBB