Forums :: Resources :: Features :: Photo Gallery :: Vintage Radio Shows :: Archives
Support This Site: Contributors :: Advertise


It is currently Nov Thu 14, 2019 6:14 pm


All times are UTC [ DST ]





Post New Topic Post Reply  [ 19 posts ] 
Author Message
 Post subject: Magnavox console record player auto play not working
PostPosted: Jun Fri 20, 2014 7:46 pm 
New Member

Joined: Jun Fri 20, 2014 7:34 pm
Posts: 6
Ok, I am VERY new to the record player scene. After bringing my first record player home and getting the correct needle, she is still returning the arm without playing music when on auto. It will play records when I manually place needle. I have no idea where to begin and any advice is welcome.
Not sure if it is related or not, but the speakers seem to work fine when the radio is on, but one side cuts out and comes back in when the record player is on.
The model/finish number is PE6714MA41


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Fri 20, 2014 8:05 pm 
Member

Joined: Jan Thu 01, 1970 1:00 am
Posts: 2658
Location: Haledon NJ USA
Are you starting it with the record(s) on top and letting them drop during the cycle? If you're starting it with the record acually on the turntable it will shut off.

Ken D.


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Fri 20, 2014 9:07 pm 
Member
User avatar

Joined: Mar Tue 04, 2014 3:29 am
Posts: 2073
Location: Long Beach, CA 90808
I'm afraid that the Magnavox model number is basically worthless here.... is this a console, consolette, portable???

A picture would be helpful, but most likely a chassis number from the Amp or Turntable itself will be needed to give meaningful advice.

_________________
Aloha, Ken

No Console Left Behind!
Come join us @ http://vintagehifi.net/


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Fri 20, 2014 10:53 pm 
New Member

Joined: Jun Fri 20, 2014 7:34 pm
Posts: 6
My bad :D It is a console record player. I have recorded what it is doing, but it won't let me attach the link because I am a new user.


Where can I find those numbers? I don't see anything on the turntable itself.


Attachments:
IMG_20140620_163209.jpg
IMG_20140620_163209.jpg [ 91.88 KiB | Viewed 4544 times ]
IMG_20140620_163145 (1).jpg
IMG_20140620_163145 (1).jpg [ 65.7 KiB | Viewed 4544 times ]
Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Fri 20, 2014 11:18 pm 
Member
User avatar

Joined: Mar Tue 04, 2014 3:29 am
Posts: 2073
Location: Long Beach, CA 90808
So from your picture we can see that this is without a doubt a solid state unit from some time in the early 70's.

You will need to remove the rear panel from the console to find them.

You will find the numbers stamped on the side of the metal chassis... and in the case of the turntable it will either be stamped on the bottom of the motor board or it could be a label that is pasted on to the bottom side of the TT just about anywhere.

_________________
Aloha, Ken

No Console Left Behind!
Come join us @ http://vintagehifi.net/


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Fri 20, 2014 11:42 pm 
New Member

Joined: Jun Fri 20, 2014 7:34 pm
Posts: 6
Numbers I found-
Amp-7420
761101/68- This number was also on it

Turn Table-CA ref7423 model-W750/01/AC
On a sticker on the turntable- W700/W800 series LR13392
Made in England

*Just tried to play it again and the arm goes over, sets down, plays for a second, and then returns. After that it will just keep going back and forth without setting the needle down, until it shuts itself off.


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sat 21, 2014 12:11 am 
Member

Joined: Apr Wed 09, 2008 3:37 am
Posts: 14346
Location: Little Rock, Arkansas
Sounds like it has a condition known as rejectitis. You need the Photofact to be able to find out what is causing it.


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sat 21, 2014 4:00 pm 
Member

Joined: Oct Tue 26, 2010 1:59 am
Posts: 367
Location: 42025
I think I see your problem.

On the turntable see the 2 plastic tabs? one on upper left other lower right. They are the turntable lock down tabs used for shipping. Your table looks to be in lock.

Slide them left upper on slide down. Bottom one slide to the left I think. When locked you see a hole for a screw. Make sure you do not see this hole.When unlocked the table should float on springs. If it is locked it will not work in auto.


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sat 21, 2014 4:15 pm 
Member

Joined: Oct Tue 26, 2010 1:59 am
Posts: 367
Location: 42025
Here is a edit photo of your turntable green box is the lock tabs. You might have to push on table to slide them but once you do it might work like it should.

Image


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sat 21, 2014 6:11 pm 
New Member

Joined: Jun Fri 20, 2014 7:34 pm
Posts: 6
Thanks for all the input! Unfortunately, unlocking it didn't fix the problem :( I have been watching YouTube videos and going the full restoration thread. At some point I will try and take it apart to fix the rejectitis!


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sat 21, 2014 6:34 pm 
New Member

Joined: Jun Fri 20, 2014 7:34 pm
Posts: 6
Any idea where I can find the Photofact for this model? From what I am seeing when searching, it seems like a haynes manual, but for old radios instead of cars...
I am looking for the correct one on dxzone(SAMs photofact), but can't seem to find mine. The numbers pulled of the chassis don't match, nothing matches the model number that was on the sticker on the back, the numbers taken off of the amp don't match, and the sticker on the turntable says it's a w700/w800 series, but that is no where in the listing.


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sat 21, 2014 11:59 pm 
Member

Joined: Oct Tue 26, 2010 1:59 am
Posts: 367
Location: 42025
there tables were almost all the same. This link has a service guide for one close to it. What changed was basic stuff lart needle cart style and older ones used two drive wheels.

To remove the table is easy twist lock tabs and they pull out. One out table lefts out and just unplugs.

http://www.antiqueradios.com/forums/vie ... p?t=129717


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sun 22, 2014 3:19 am 
Member
User avatar

Joined: Jan Thu 01, 1970 1:00 am
Posts: 3350
Location: Poplar Bluff, MO USA
Generally constant cycling on these changers is usually caused by the smaller white gear or intermediate gear
being out of time with the large cycling cam. The cause of them jumping out of time is binding in the bearing for
the cycling cam. Try turning the cam with your hand a few degrees it should move fairly free unless it's in the
middle of cycling.

If this is the case your changer will need extensive disassembly cleaning and relubing. The link posted by Troydog
has the factory manual that I posted some time back. Read the description of the operation of the turntable before
you start trying to do anything to it. I'm very familiar with these units from the time I was a Magnavox Tech.

The difference between all of the single idler changers are very minor and relate to features and cosmetics.

_________________
However beautiful the strategy, you should occasionally look at the results.
Winston Churchill


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Jun Sun 22, 2014 3:34 am 
New Member

Joined: Jun Fri 20, 2014 7:34 pm
Posts: 6
Thank you!


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Sep Wed 04, 2019 2:12 pm 
New Member

Joined: Sep Tue 03, 2019 7:08 pm
Posts: 7
Hi, I'm new here.
My mom has the same changer. I had it running great, but now it just cycles over and over. Is there a diagram of the main cam, how it cycles and returns to resting place for play? Thanks.

John :?:


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Sep Thu 05, 2019 10:07 pm 
Member
User avatar

Joined: Dec Tue 23, 2014 6:51 pm
Posts: 1387
Location: N. Palm Bch, Fl.
Hi John. Welcome to the club. Is yours the W700 or W800 series player? Pictures would help. You should be able to post pictures now. Just resize them if there larger than 800X800. I found a Magnavox Service Manual for the W800 series on line. I was able to use it to restore my W701 years ago.

Freeman


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Sep Tue 10, 2019 11:16 pm 
New Member

Joined: Sep Tue 03, 2019 7:08 pm
Posts: 7
i took the cams out and cleaned and re-greased and/or lubed it all. It's all back together, but now I cannot switch to the auto mode. It is stuck. It will turn to manual, though. any help is appreciated. Thanks.

I'll post some pictures shortly.


Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Sep Tue 10, 2019 11:47 pm 
New Member

Joined: Sep Tue 03, 2019 7:08 pm
Posts: 7
Here are some pictures. It is 700.


Attachments:
Magnavox 1.JPG
Magnavox 1.JPG [ 321.04 KiB | Viewed 457 times ]
Magnavox 2.JPG
Magnavox 2.JPG [ 269.31 KiB | Viewed 457 times ]
Magnoavox 3.JPG
Magnoavox 3.JPG [ 374.62 KiB | Viewed 453 times ]
Magnavox 4.JPG
Magnavox 4.JPG [ 361.68 KiB | Viewed 453 times ]
Top
 Profile  
 
 Post subject: Re: Magnavox console record player auto play not working
PostPosted: Sep Wed 11, 2019 4:45 pm 
New Member

Joined: Sep Tue 03, 2019 7:08 pm
Posts: 7
Okay, I finally have the item repaired and working great. I only lost the E washers about 2 dozen times, but they were recovered. :lol:

My mom's sister has a similar changer with most of the same problems Hopefully, nothing is broken or missing or disintegrated. Wish me luck.

Thanks to all you guys.

John


Top
 Profile  
 
Post New Topic Post Reply  [ 19 posts ]  Moderator: Alan Voorhees

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 10 guests



Search for:
Jump to:  




























Privacy Policy :: Powered by phpBB